Podcast de Tecnología y Noticias de Tecnología

Debes de tener cuidado si tienes una computadora #Apple

Pon mucha atención, debes de tener cuidado si tienes una computadora #Apple. Un fallo crítico de seguridad presente en la última versión del sistema operativo de los ordenadores Mac, conocida como High Sierra, permite a cualquier persona entrar en el sistema con privilegios de superusuario (root) y tener por tanto acceso a todo el contenido almacenado en el ordenador.

El fallo afecta únicamente a la última versión de este sistema operativo de Apple, lanzada el pasado mes de septiembre, y es fácil de reproducir. Basta con identificarse en la pantalla de registro al iniciar el ordenador como root (la cuenta de administrador del sistema por defecto en sistemas basados en Unix, cómo macOS o Linux), dejar el campo de contraseña en blanco y pulsar varias veces seguidas el botón de acceso.

Este procedimiento funciona además para cambiar cualquier configuración del sistema una vez se ha accedido a él como cualquier otro usuario. Basta poner nombre de usuario root, dejar la contraseña en blanco y pulsar varias veces el botón de validación para tener acceso a cualquier rincón del sistema. También es posible acceder de forma remota a lOs equipos si tienen activada la función de compartir escritorio (por defecto está desactivada).

Según Bill Evans, portavoz de Apple, la compañía está trabajando ya en una actualización de seguridad que soluciona el problema. La única forma de corregirlo, de momento, es creando una contraseña segura para el usuario root, que en los sistemas macOS está oculto por defecto.

A su vez, en un comunicado oficial, la compañía insta a crear una contraseña para el usuario root. “Para habilitar el usuario Root y establecer una contraseña, siga las instrucciones que se encuentran aquí. Si el usuario Root está ya habilitado, para garantizar que no quepa la opción de una contraseña en blanco, siga las instrucciones de la sección ‘Cambiar la contraseña de root'”

Críticas a la compañía

Varios expertos han criticado en la red la forma en la que se ha hecho pública esta vulnerabilidad. El desarrollador Lemi Orhan Ergin la comunicó en un escueto tweet publicado sin previo aviso.

Por lo general, entre desarrolladores y expertos de seguridad, se tiende a seguir un código ético que pide comunicar primero a la empresa el descubrimiento, de forma que los parches de seguridad puedan estar listos en el momento de hacerse pública la vulnerabilidad. “Hacer esto pone millones de ordenadores en riesgo”, asegura el desarrollador Amir Omidi.

El fallo, en cualquier caso, es lo bastante grave como para sacar los colores a Apple, una compañía que presume siempre de tener un sistema operativo más seguro que el de la competencia. En la web que detalla las medidas seguridad del sistema operativo macOS, Apple recomiendo expresamente actualizar a la última versión del sistema operativo, High Sierra, para estar protegido contra cualquier ataque de forma sencilla.

Para muchos usuarios de Mac, descontentos en los últimos años con la prioridad que Apple parece estar dando a su otro sistema operativo, iOS, este fallo de seguridad evidencia el escaso interés que la empresa de Cupertino pone en el mercado de la informática tradicional.

El Mundo

Los comentarios están cerrados.